Clash of Lords 2 Today: 7    Total Posts: 45379

Moderator: Dragoneyr


Create Thread

[Chat(Android)] Can't install all 3 different apk file, error code -18 on googleplay

[Copy link] 1/874

Posted on 4/13/18 7:40:06 AM | Show thread starter's posts only

Hi I've tried clrearing data on googleplay and google play games, restart device install apk or download from googleplay, tried it both on device or sd card butstill cant install the game, please fix it, I've quit castle clash 'coz I can't download last time maybe this is the same problem that's going on with this col2, please I love this soo much more than CC and ai fon't want this game right now, both i have been playing since the game started..

I have tried this 3 apk posted in this site and from your reply in googleplay, they don't work, I have android version 4.4.1
Col2_en_256_a.apk, col2_en238(not sure, already deleted it), m3egcxgxihqj3-binary1.apk.

Please fix, I won't be able to deploy my heroes and guild clash will start a few hours.

Posted on 4/13/18 8:02:25 AM | Show thread starter's posts only

This goes out of my field of expertise, but I have tried looking some stuff up.

Could there be any app on your phone which prevents apk's from being installed? Twilight might be a problem (though I never heard of it before)
- Disabling this app or deleting it outright might work.
Is there a problem with the apk you're trying to install?
- Try installing a different apk which you know works for sure.
- Try disabling Verify apps in Security. This will leave your phone vulnerable to malicious codes though inserted into apps.

If you're looking for directions, (links to external websites) here and here are my sources.

Hope this helps!

The apprentice turns against his master